Install a more recent Mono

OpenSUSE 15.1 includes Mono 5.10. OpenSim Version 0.9.1 requires at least Mono Version 5.12. OpenSim Arriba does not need the upgrade and can be run with OpenSUSE 15.1 without problems.

Attention! In the absence of an official upgrade package, a private mono repository is used here. This allows an upgrade to (at test time) Mono 5.20, but you have to trust the user “Hammer Faceman (Warhammer40k)”!

To upgrade, you must first enter a new repository (see Package Selection):

http://download.opensuse.org/repositories/home:/Warhammer40k:/Mono:/Factory/openSUSE_15.1_Update/

Now we force Yast to accept the repository by deactivating all other repositories. In contrary, after the installation we deactivate the Mono repository to avoid that it will be included for OpenSUSE updates. As long as the Warhammer40k repository is active, the recent Mono version can be installed:

  • mono-complete

By this selection, many other dependent packages are also being installed. If particular dependencies cannot be solved within the Warhammer40k repository, the choice is available to install the missing packages from the (deactivated) OpenSUSE repository: Yes, these packages shall be taken from OpenSUSE!

Scroll to Top